URL Not Loading in Webview (redirection)

When I am trying to load this http://feeds.feedblitz.com/~/33712999/0/technicallypersonal~Top-Biking-Apps-for-Android-and-iOS-iPhoneiPad/ kind of urls in an UIWebView and they do not load (I believe it's because of the redirection)

What can I do to make them work?

Answers


You say you're getting a blank page, but it works fine for me. I have a UIWebView hooked up to an IBOutlet named webview, and then I have a viewDidLoad that does:

- (void)viewDidLoad
{
    [super viewDidLoad];

    [self.webview loadRequest:[NSURLRequest requestWithURL:[NSURL URLWithString:@"http://feeds.feedblitz.com/~/33712999/0/technicallypersonal~Top-Biking-Apps-for-Android-and-iOS-iPhoneiPad/"]]];
}

I've done that and it works fine. So, you say that you just get a blank page, so I wonder if your IBOutlet is working. Try just a simple:

- (void)viewDidLoad
{
    [super viewDidLoad];

    [self.webview loadHTMLString:@"<html><body>Hello, World!</body></html>" baseURL:nil];
}

If that works, then the problem is loading from the web, in which case I'd suggest trying different URLs with the loadRequest method, to see if it's all URLs, or just your particular URL. If the loadHTMLString doesn't work, then it's got to be something simple like your IBOutlet is not set up correctly, or something like that.


Need Your Help

Sun, Audio-player and Sound I/O

java javasound jmf sun audio-player

I have a few questions related to Sun, Audio-player and Sound Input/Output