how to determinate which conflicts or lack or libraries when uploading rails server?

I am very very new on rails, and I have the problem that I am trying to set my project on local machine (the project was already started) and I get tons of error, I firstly did a bundle install and after download all gems and libraries I tried with rails server , my problem is that I get many errors, and I dont know what I have to install or do in order to make it run.

Any idea? here is my shell result

I think I have to install some libraries.. any idea of these problems?

C:/Ruby200/lib/ruby/gems/2.0.0/gems/listen-1.0.2/lib/listen/adapter.rb:195:in `
require': cannot load such file -- wdm (LoadError)

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/listen-1.0.2/lib/listen/adapter
.rb:195:in `load_dependent_adapter'

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/listen-1.0.2/lib/listen/adapter
s/windows.rb:33:in `load_dependent_adapter'

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/listen-1.0.2/lib/listen/adapter
.rb:187:in `usable?'

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/listen-1.0.2/lib/listen/adapter
s/windows.rb:25:in `usable?'

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/listen-1.0.2/lib/listen/adapter
.rb:179:in `usable_and_works?'

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/listen-1.0.2/lib/listen/adapter
.rb:49:in `block in select_and_initialize'

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/listen-1.0.2/lib/listen/adapter
.rb:47:in `each'

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/listen-1.0.2/lib/listen/adapter
.rb:47:in `select_and_initialize'

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/listen-1.0.2/lib/listen/listene
r.rb:267:in `initialize_adapter'

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/listen-1.0.2/lib/listen/listene
r.rb:259:in `setup'

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/listen-1.0.2/lib/listen/listene
r.rb:49:in `start'

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/guard-1.8.0/lib/guard.rb:194:in
 `block in start'

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/guard-1.8.0/lib/guard.rb:368:in
 `block in within_preserved_state'

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/guard-1.8.0/lib/guard.rb:365:in
 `synchronize'

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/guard-1.8.0/lib/guard.rb:365:in
 `within_preserved_state'

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/guard-1.8.0/lib/guard.rb:190:in
 `start'

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/guard-1.8.0/lib/guard/cli.rb:11
0:in `start'

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/thor-0.18.1/lib/thor/command.rb
:27:in `run'

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/thor-0.18.1/lib/thor/invocation
.rb:120:in `invoke_command'

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/thor-0.18.1/lib/thor.rb:363:in
`dispatch'

        from C:/Ruby200/lib/ruby/gems/2.0.0/gems/thor-0.18.1/lib/thor/base.rb:43
9:in `start'

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/guard-1.8.0/bin/guard:6:in `<to
p (required)>'

from C:/Ruby200/bin/guard:23:in `load'
from C:/Ruby200/bin/guard:23:in `<main>'

Answers


This is just one error, it's just showing you the entire stack. That is, look at the first line: "C:/Ruby200/lib/ruby/gems/2.0.0/gems/listen-.0.2/lib/listen/adapter.rb:195:in 'require': cannot load such file -- wdm (LoadError)"

That is the origin of the error. The lines after that show you what methods were called to get there.

So you only need to solve "C:/Ruby200/lib/ruby/gems/2.0.0/gems/listen-.0.2/lib/listen/adapter.rb:195:in 'require': cannot load such file -- wdm (LoadError)"

I originally found the answer to this here: Guard won't load WDM

The Listen gem needs the WDM Gem to work properly on Windows. You can accomplish this by adding this line to your Gemfile:

gem 'wdm', '>= 0.1.0' if RbConfig::CONFIG['target_os'] =~ /mswin|mingw/i

This line simply says that if your operating system is 'mwin' or 'mingw', the 'wdm' gem is needed.

Once you've saved your Gemfile, run bundler install again to make sure that the wdm gets installed.


Need Your Help

How to run Application with SQL Database on a machine that dosen't have SQL Server Installed

c# sql database deployment connection

I have developed an application that have a slider that showing some data from a

Java/Groovy double for statement question

java groovy

This is a Java/Groovy question, im doing this function to implement in a search mechanism in my website. I have two lists:

About UNIX Resources Network

Original, collect and organize Developers related documents, information and materials, contains jQuery, Html, CSS, MySQL, .NET, ASP.NET, SQL, objective-c, iPhone, Ruby on Rails, C, SQL Server, Ruby, Arrays, Regex, ASP.NET MVC, WPF, XML, Ajax, DataBase, and so on.