how to install ruby 2.0 in debian 6?

I want o install ruby 2.0 and I have followed many tutorials, but none of them works, and the defaul repo apt-get install ruby brings me the 1.8 version (and due is debian has restrictions to update it if is not through the repo) any way to do it?

Ive tried this way

cd /usr/src
wget ftp://ftp.ruby-lang.org/pub/ruby/2.0/ruby-2.0.0-p0.tar.gz
tar xjf ruby.xxx.tar.bz2
cd rubyxxx
./configure --enable-shared
make 
make install

and just that, I get error on the next steps, when I make a ruby -version I get this

-bash: /usr/bin/ruby: No such file or directory

the end of the tuto install

cd ext/openssl/
ruby extconf.rb
make install

cd ../readline/
ruby extconf.rb
make install

gem update --system

any idea how to do this in debian 6? thanks

Answers


If it's a server, you may want to take a look at RVM (https://rvm.io/). It would make your install as simple as :

curl -L https://get.rvm.io | bash -s stable --rails --autolibs=enabled


Need Your Help

custom UITextView resizing when enter is pressed

objective-c ios uitableview resize uitextview

I have a UIViewController with a custom UITextView in it (CodeTextView) and left of this text view I have a custom UITableView (LinesTableView). LinesTableView contains the line numbers aligned to ...

Emberjs - unable to query for embedded model or association

ember.js ember-data

A small portion of this fiddle: http://jsfiddle.net/v2t67/ is displayed in my question, but my problem is that i am unable to query for the json of the child model ie the comment model. As of no...

About UNIX Resources Network

Original, collect and organize Developers related documents, information and materials, contains jQuery, Html, CSS, MySQL, .NET, ASP.NET, SQL, objective-c, iPhone, Ruby on Rails, C, SQL Server, Ruby, Arrays, Regex, ASP.NET MVC, WPF, XML, Ajax, DataBase, and so on.