Getting an error connecting web service using SOAPUI

I'm getting the following error every time I run my script using SOAPUI. It says connection refused. Please Help. It seems to me that there's some firewall issue but when I talk to my network people but they don't think it's the firewall.

java.lang.NullPointerException
at com.eviware.soapui.impl.rest.panels.request.views.html.HttpHtmlMessageExchangeResponseView.writeHttpBody(HttpHtmlMessageExchangeResponseView.java:211)
at com.eviware.soapui.impl.rest.panels.request.views.html.HttpHtmlMessageExchangeResponseView.setEditorContent(HttpHtmlMessageExchangeResponseView.java:190)
at com.eviware.soapui.impl.rest.panels.request.views.html.HttpHtmlMessageExchangeResponseView.buildContent(HttpHtmlMessageExchangeResponseView.java:106)
at com.eviware.soapui.impl.rest.panels.request.views.html.HttpHtmlMessageExchangeResponseView.getComponent(HttpHtmlMessageExchangeResponseView.java:66)
at com.eviware.soapui.support.editor.Editor.addEditorView(Editor.java:83)
at com.eviware.soapui.impl.support.components.ResponseMessageXmlEditor.<init>(ResponseMessageXmlEditor.java:49)
at com.eviware.soapui.impl.wsdl.support.MessageExchangeResponseMessageEditor.<init>(MessageExchangeResponseMessageEditor.java:33)
at com.eviware.soapui.impl.wsdl.support.MessageExchangeResponseMessageEditor.<init>(MessageExchangeResponseMessageEditor.java:28)
at com.eviware.soapui.impl.wsdl.teststeps.actions.ShowMessageExchangeAction.buildResponseTab(ShowMessageExchangeAction.java:192)
at com.eviware.soapui.impl.wsdl.teststeps.actions.ShowMessageExchangeAction.buildContent(ShowMessageExchangeAction.java:98)
at com.eviware.soapui.impl.wsdl.teststeps.actions.ShowMessageExchangeAction.buildFrame(ShowMessageExchangeAction.java:88)
at com.eviware.soapui.impl.wsdl.teststeps.actions.ShowMessageExchangeAction.actionPerformed(ShowMessageExchangeAction.java:76)
at com.eviware.soapui.support.action.swing.DefaultActionList.performDefaultAction(DefaultActionList.java:107)
at com.eviware.soapui.impl.wsdl.panels.testcase.JTestRunLog$LogListMouseListener.mouseClicked(JTestRunLog.java:228)
at java.awt.AWTEventMulticaster.mouseClicked(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$200(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue$4.run(Unknown Source)
at java.awt.EventQueue$4.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Answers


Try disabling the proxy in SOAP-UI, which indicated in the attached screen shot. Or Give a valid proxy connection under Proxy settings in SOAP UI Global preference.

By disabling the proxy preference SOAP UI may work in offline.

Hope it might solve your issue.

Thanks, Madhan


Is this servie or your server is password protected? You can try these things, Find end point url in ur wsdl (under soap: address location tag), execute it in browser. Hopefully it will be returning some error, That means this particular webservice or connection is not available. If it is executing succesfully then try to find the logs or error from server for your request and post here.

Thanks, ambuj


I have got same error with old version of soapUI. when i use SoapUI 5.2.0 it worked.


Need Your Help

Evaluate complete subtree existence of

xml xpath

I often want to filter one element using an XPATH expression upon the existence of some element in an entire subtree and I was wondering if it is possible to let an xpath expression match all resul...

Jquery easy-ui fire up a click element event

events datagrid click jquery-easyui

I want to ask how is it possible to fire a click event from a div element containing into an Easy-ui datagrid?.

About UNIX Resources Network

Original, collect and organize Developers related documents, information and materials, contains jQuery, Html, CSS, MySQL, .NET, ASP.NET, SQL, objective-c, iPhone, Ruby on Rails, C, SQL Server, Ruby, Arrays, Regex, ASP.NET MVC, WPF, XML, Ajax, DataBase, and so on.