Install and especific checkout version of bundle symfony2

I would like to install and especific checkout version of a bundle in my project. When I was developing the checkout version of the bundle I was using was dev-master 5677b63, but then, I updated using composer and I got installed the newest version, which has a small piece of code that kind of destroys everything (it was an issue that they solved). I was wondering if I could tell composer to install the old checkout of dev:master and not the latest one. Is that even possible?

Answers


I believe it could be done with something like this:

{
    ...
    "require": {
        "foo/bar": "dev-master#1333333333333333333333333333333333333337"
    }
    ...
}

Obviously, you would need to replace 1333333333333333333333333333333333333337 with commit ID...

Source: https://coderwall.com/p/ub4ejg


Need Your Help

How to replace a xml tag with DTD entity

xml dtd liquibase

I can replace a xml Attribute values using DTD Entity declaration using following methode

Why tornado removed database after v3.0

python mysql database

what is the reason that database module is removed? Just because the database module is not async?

About UNIX Resources Network

Original, collect and organize Developers related documents, information and materials, contains jQuery, Html, CSS, MySQL, .NET, ASP.NET, SQL, objective-c, iPhone, Ruby on Rails, C, SQL Server, Ruby, Arrays, Regex, ASP.NET MVC, WPF, XML, Ajax, DataBase, and so on.