Debugging hangs with “Application is waiting for debugger to attach” on Android with Eclipse

I know that this issued has been assessed a number of times but I can not resolve it. I'm using Eclipse v. 4.2.2, Android API 19, Windows 7 64 bit. I have the same issue on both a Kitkat virtual device and a Nexus 5 device. I'm trying to debug an almost empty application and the last Console output is always:

[2014-06-04 11:56:03 - delme] Attempting to connect debugger to 'com.example.delme' on port 8611
[2014-06-04 11:56:04 - delme] Launch error: Failed to connect to remote VM

I tried all the following steps with no success:

  • adding <uses-permission android:name="android.permission.SET_DEBUG_APP"></uses-permission>
  • adding 127.0.0.1 localhost in host configuration file (C:\Windows\System32\drivers\etc\hosts)
  • only 1 instance of eclipse was open
  • only 1 device is connected
  • restarted Eclipse and windows and adb kill-server and rebooted the pc
  • restarted the device

Thank you very much.

Answers


Ok, resolved the issue by installing a new Eclipse-ADT bundle. My old version was a Juno with ADT manually added, but I don't know what was the problem.


Need Your Help

Android Certificate Signature & App name

java android xml certificate signature

I'm using Java (J2SE) to create a desktop application. It has a function that check if two unknown .apk files (for ex app1.apk and app2.apk) are same application or not. My idea is comparing the

About UNIX Resources Network

Original, collect and organize Developers related documents, information and materials, contains jQuery, Html, CSS, MySQL, .NET, ASP.NET, SQL, objective-c, iPhone, Ruby on Rails, C, SQL Server, Ruby, Arrays, Regex, ASP.NET MVC, WPF, XML, Ajax, DataBase, and so on.