Eclipse on Ubuntu with Apache2 and Subversion

Trying to setup Eclispe. The Eclipse help/about/installed software says:

Eclipse Platform 3.5.2 Subclipse 1.0.0 Version Control with Subversion 1.1.1

The Subclipse wiki I followed is here

I have installed the libsvn-java app - discussed here

I added the line "-Djava.library.path=/usr/lib/jni" to the eclipse.ini file

I checked the Eclipse help/about/confirguration settings and both of these lines are listed: eclipse.vmargs=-Djava.library.path=/usr/lib/jni java.library.path=/usr/lib/jni

I checked that those files are in those directories. Still, when I check the preferences>team>svn an error dialog shows:

Failed to load JavaHL Library. These are the errors that were encountered: no libsvnjavahl.1 in java.library.path Incompatible JavaHL library loaded 1.3.x or later required

Testing JavaHL libraries is discussed here.

I downloaded the tarbal and ran it in a folder on my desktop with no problems. Then, I followed the instructions and placed that file INSIDE the path (usr/lib/jni/testJavaHL) and ran it from there. There are 50 tests performed and each one of them came back with this same error (posting only one for brevity):

50) testCommitRevprops(org.tigris.subversion.javahl.BasicTests)java.io.FileNotFoundException: /usr/lib/jni/testJavaHL/local_tmp/greek_files/iota (No such file or directory)
 at java.io.FileOutputStream.open(Native Method)
 at java.io.FileOutputStream.<init>(FileOutputStream.java:209)
 at java.io.FileOutputStream.<init>(FileOutputStream.java:160)
 at org.tigris.subversion.javahl.WC.materialize(WC.java:70)
 at org.tigris.subversion.javahl.SVNTests.buildGreekFiles(SVNTests.java:303)
 at org.tigris.subversion.javahl.SVNTests.setUp(SVNTests.java:222)
 at org.tigris.subversion.javahl.RunTests.main(RunTests.java:111)

FAILURES!!!
Tests run: 50,  Failures: 0,  Errors: 50

Any ideas as to how/why the "local_tmp/greek_files/iota" is appended to the directory? I assume that's my problem..

I'm also having a problem with new>repository location = ...as the directory location of my svn repository is one level above the home directory - which is prepended to whatever I place in the dialog box - resulting in this error:

svn: '/home/ricalsin/file:/home/svn' does not exist

Thank you for any help.

Answers


Is there a reason you're using the 1.0.0 version of Subclipse for eclipse? That's a very very old client for the 3.5.x version of eclipse.

Go to Subclipse and get the 1.4.x or 1.6.x install depending upon your Subversion server install. Get 1.4.x of Subclipse if your Subversion server is running 1.5.x. Get 1.6.x of Subclipse if your Subversion server is running 1.6.x.


Need Your Help

WPF Service Call to WCF Cannot access a disposed object

.net wpf vb.net wcf

We have a WPF app that returns data from a WCF Service.

How to deduce the count of the vacancies next to the name of the city?

php sql yii

I made a sql query that counts of jobs in a particular city

About UNIX Resources Network

Original, collect and organize Developers related documents, information and materials, contains jQuery, Html, CSS, MySQL, .NET, ASP.NET, SQL, objective-c, iPhone, Ruby on Rails, C, SQL Server, Ruby, Arrays, Regex, ASP.NET MVC, WPF, XML, Ajax, DataBase, and so on.