xCode Release build screws up uiview

I have an iOS project I have been working on for the last few months. It is running great on the iPhone 3GS and up and the iPod touch 3g and up. It works on an iPod touch 2g and iPhone 3G if i compile the build in debug mode. Whenever I archive the app with xCode to distribute it (it compiles in release mode) and will not work on the devices mentioned above.

"Not working" is referring to a problem I have with a UIView. When I touch a view containing multiple of my subviews the subviews don't move as implemented with -(void)touch began... etc and just do random moves.

This doesn't happen when I build in debug mode.

If I cannot fix this problem then I will not be able to support older devices, which would't be great...

Could this have something to do with armv6 vs. armv7?

Any answers?

Answers


If you are using Xcode 4.2, you need to add -mno-thumb to "Other C Flags" for armv6 architecture. See iOS5 Xcode4.2 floating-point byte align error? for detail.

I've heard that Xcode 4.2.1 fixed this problem, but I'm not sure.


Need Your Help

efficient library to recommend product based on user history

python algorithm performance recommendation-engine

I have a database of which products every user has viewed and I want to recommend a product based on what similar users have viewed. Is there a Python library that can achieve this? I don't need Ne...

How to check if a fragment is visible

android android-fragments

I have a layout that holds 3 fragments.