ModalPopupExtender not working in IE but working in FF

I am facing a critical problem i am using ajaxmodalpopupextender in my page. It's working fine in FireFox with a great view but it's not working fine that is it displays in a side in IE and background is also not looking as is set.

I tried almost all things like

  1. Using CSS
  2. Having the panel in div and setting

    div style="position:absolute;left:140;top:100;"
    
  3. Doctype of page to xhtml

But there is nothing to get it all. Please help.

The Doctype is as : -

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

Any one please help me i am stucked..

Please helpppppppppp.

This edit will be visible only to you until it is peer reviewed.

what version of IE you are trying this?Can you paste ur code snippet here?

GridView Here: -

<GridView id= "Grd" runat="server" AutoGenerateColumns="false" CssClass="GridStyle"    
           HeaderStyle-Font-Size="Small" Width="960" Visible="false">   
          <Columns>             

          'Columns goes here             
          <asp:TemplateField HeaderText="Action" HeaderStyle-Width="310px" ItemStyle-HorizontalAlign="Left">   
          <ItemTemplate>   
              <asp:Button ID="btnDelete" runat="server" Text="Delete" OnClick="btnDelete_Click"    
              CommandArgument='<%#Eval("intHireEnquiryID") %>' />   
              <asp:Button ID="btnPlace" runat="server" Text="Place" OnClick="btnPlace_Click"     
              CommandArgument='<%#Eval("intHireEnquiryID") %>' />   

          </ItemTemplate>   
          </asp:TemplateField>   
          </Columns>             
          </GridView>           

ModalPopup Here: -

<asp:UpdatePanel ID="upPopupPnl" runat="server" UpdateMode="Conditional">  
            <ContentTemplate>              
            <asp:Panel runat="server" ID="pnlPopup" Width="300px" Height="300px" BackColor="Azure"   
            style="overflow:auto;border-color:Black;border-style:solid;border-width:2px;">  
            <table><tr><td colspan="2" style="width:300px;">  
            <asp:RadioButtonList ID="rbl1" runat="server">  
            </asp:RadioButtonList>            
            </td></tr>  
            <tr><td style="text-align:center;">  
            <asp:Button ID="btnPlacePopup" runat="server" Text="Place" Width="100" Height="35" Font-Bold="true"   
            OnClick="btnPlacePopup_Click" />  
            </td>  
            <td style="text-align:center;">  
            <asp:Button ID="btnCancel" runat="server" Text="Cancel" Width="100" Height="35" Font-Bold="true" />  
            </td></tr>  
            </table>  
            </asp:Panel>  
            <asp:Button ID="btnDummy" runat="server" Text="Not Display" style="display:none;"/>  
            <ajaxtk:ModalPopupExtender ID="actPopup1" runat="server" TargetControlID="btnDummy" BackgroundCssClass="modalBackground"    
            PopupControlID="pnlPopup" CancelControlID="btnCancel">  
            </ajaxtk:ModalPopupExtender>   
            </ContentTemplate>  
            </asp:UpdatePanel>  

The Css class is as: -

.modalBackground   
{   
  background-color:#B3B3CC;   
  opacity:0.5;  
} 

Code behind: -

dim intHireEnquiryIDas integer   
Protected Sub btnPlace_Click(ByVal sender As Object, ByVal e As System.EventArgs)  
        intHireEnquiryID = CType(sender, Button).CommandArgument  
        Dim EXP As New Exception  
        Dim params(0) As SqlParameter  
        params(0) = New SqlParameter("@intHireEnquiryID", intHireEnquiryID)  
        Dim DS As New DataSet  
        DS = execQuery("spAgent_Get_Assigned_Workers", executionType.SPExecuteForDS, EXP, params)  
        If DS.Tables(0).Rows.Count > 0 Then  
            rbl1.DataSource = DS  
            rbl1.DataTextField = "WorkerDetail"  
            rbl1.DataValueField = "intWorkerID"  
            rbl1.DataBind()              
        End If  
        upPopupPnl.Update()  
        actPopup1.Show()  
    End Sub  

It's Working great in FireFox but not rendering the popup in center in IE neither it's background is rendering as is set. I am totally stucked please help thnx in advance.

Answers


I have removed the problem the problem was there were some comments on the page like

<!--headersonly


Page Directives. Please dont go away with DW templates


headersonly//-->

<!--<%@ Register Src="~/uc/uc_pager.ascx" TagName="pager" TagPrefix="uc1" %> -->

I removed all that and it working fine in IE also.

But can any one explain what was the reason?


Need Your Help

How to start a github repository with a few versions that are in zip files

git repository

I am new to github and trying to start a repository. I keep searching for how to's on here but the the things people mention dont seem to exist and they dont link directly.

Why is it impossible to override a getter-only property and add a setter?

c# .net design properties getter-setter

Why do you think (or, why is it good that) Microsoft chose not to allow:

About UNIX Resources Network

Original, collect and organize Developers related documents, information and materials, contains jQuery, Html, CSS, MySQL, .NET, ASP.NET, SQL, objective-c, iPhone, Ruby on Rails, C, SQL Server, Ruby, Arrays, Regex, ASP.NET MVC, WPF, XML, Ajax, DataBase, and so on.