pip install requirement fails

I am facing an issue while trying to install the requirements for my django project.

I am unable to figure out why I'm getting this error.

Can someone lead me in the right direction?

 >Running setup.py egg_info for package django-staticfiles
    Traceback (most recent call last):
      File "<string>", line 14, in <module>
      File "/Users/glosseyvilly/Desktop/Workspace/chris_dev/mysite-env/build/django-staticfiles/setup.py", line 128, in <module>
        'versiontools >= 1.6',
      File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/core.py", line 113, in setup
        _setup_distribution = dist = klass(attrs)
      File "build/bdist.linux-i686/egg/setuptools/dist.py", line 260, in __init__
      File "build/bdist.linux-i686/egg/setuptools/dist.py", line 284, in fetch_build_eggs
      File "build/bdist.linux-i686/egg/pkg_resources.py", line 563, in resolve
        plugin_projects = list(plugin_env)
      File "build/bdist.linux-i686/egg/pkg_resources.py", line 799, in best_match

      File "build/bdist.linux-i686/egg/pkg_resources.py", line 811, in obtain

      File "build/bdist.linux-i686/egg/setuptools/dist.py", line 327, in fetch_build_egg
      File "build/bdist.linux-i686/egg/setuptools/command/easy_install.py", line 446, in easy_install

      File "build/bdist.linux-i686/egg/setuptools/command/easy_install.py", line 476, in install_item

      File "build/bdist.linux-i686/egg/setuptools/command/easy_install.py", line 655, in install_eggs

      File "build/bdist.linux-i686/egg/setuptools/command/easy_install.py", line 930, in build_and_install

      File "build/bdist.linux-i686/egg/setuptools/command/easy_install.py", line 919, in run_setup

      File "build/bdist.linux-i686/egg/setuptools/sandbox.py", line 62, in run_setup
      File "build/bdist.linux-i686/egg/setuptools/sandbox.py", line 105, in run
      File "build/bdist.linux-i686/egg/setuptools/sandbox.py", line 64, in <lambda>
      File "setup.py", line 29, in <module>
        in a distutils ``setup.py`` file.
      File "/var/folders/zm/zmC41KkWH5ObUL0cyVjWL++++TI/-Tmp-/easy_install-wsSHXC/versiontools-1.8.1/versiontools/__init__.py", line 354, in format_version

      File "/var/folders/zm/zmC41KkWH5ObUL0cyVjWL++++TI/-Tmp-/easy_install-wsSHXC/versiontools-1.8.1/versiontools/__init__.py", line 183, in from_tuple

      File "/var/folders/zm/zmC41KkWH5ObUL0cyVjWL++++TI/-Tmp-/easy_install-wsSHXC/versiontools-1.8.1/versiontools/__init__.py", line 126, in __new__

      File "/var/folders/zm/zmC41KkWH5ObUL0cyVjWL++++TI/-Tmp-/easy_install-wsSHXC/versiontools-1.8.1/versiontools/__init__.py", line 279, in _find_source_tree

      File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/inspect.py", line 936, in getouterframes
        framelist.append((frame,) + getframeinfo(frame, context))
      File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/inspect.py", line 911, in getframeinfo
        lines, lnum = findsource(frame)
      File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/inspect.py", line 573, in findsource
        if pat.match(lines[lnum]): break
    IndexError: list index out of range
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):

  File "<string>", line 14, in <module>

  File "/Users/glosseyvilly/Desktop/Workspace/chris_dev/mysite-env/build/django-staticfiles/setup.py", line 128, in <module>

    'versiontools >= 1.6',

  File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/core.py", line 113, in setup

    _setup_distribution = dist = klass(attrs)

  File "build/bdist.linux-i686/egg/setuptools/dist.py", line 260, in __init__

  File "build/bdist.linux-i686/egg/setuptools/dist.py", line 284, in fetch_build_eggs

  File "build/bdist.linux-i686/egg/pkg_resources.py", line 563, in resolve

    plugin_projects = list(plugin_env)

  File "build/bdist.linux-i686/egg/pkg_resources.py", line 799, in best_match



  File "build/bdist.linux-i686/egg/pkg_resources.py", line 811, in obtain



  File "build/bdist.linux-i686/egg/setuptools/dist.py", line 327, in fetch_build_egg

  File "build/bdist.linux-i686/egg/setuptools/command/easy_install.py", line 446, in easy_install



  File "build/bdist.linux-i686/egg/setuptools/command/easy_install.py", line 476, in install_item



  File "build/bdist.linux-i686/egg/setuptools/command/easy_install.py", line 655, in install_eggs



  File "build/bdist.linux-i686/egg/setuptools/command/easy_install.py", line 930, in build_and_install



  File "build/bdist.linux-i686/egg/setuptools/command/easy_install.py", line 919, in run_setup



  File "build/bdist.linux-i686/egg/setuptools/sandbox.py", line 62, in run_setup

  File "build/bdist.linux-i686/egg/setuptools/sandbox.py", line 105, in run

  File "build/bdist.linux-i686/egg/setuptools/sandbox.py", line 64, in <lambda>

  File "setup.py", line 29, in <module>

    in a distutils ``setup.py`` file.

  File "/var/folders/zm/zmC41KkWH5ObUL0cyVjWL++++TI/-Tmp-/easy_install-wsSHXC/versiontools-1.8.1/versiontools/__init__.py", line 354, in format_version



  File "/var/folders/zm/zmC41KkWH5ObUL0cyVjWL++++TI/-Tmp-/easy_install-wsSHXC/versiontools-1.8.1/versiontools/__init__.py", line 183, in from_tuple



  File "/var/folders/zm/zmC41KkWH5ObUL0cyVjWL++++TI/-Tmp-/easy_install-wsSHXC/versiontools-1.8.1/versiontools/__init__.py", line 126, in __new__



  File "/var/folders/zm/zmC41KkWH5ObUL0cyVjWL++++TI/-Tmp-/easy_install-wsSHXC/versiontools-1.8.1/versiontools/__init__.py", line 279, in _find_source_tree



  File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/inspect.py", line 936, in getouterframes

    framelist.append((frame,) + getframeinfo(frame, context))

  File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/inspect.py", line 911, in getframeinfo

    lines, lnum = findsource(frame)

  File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/inspect.py", line 573, in findsource

    if pat.match(lines[lnum]): break

IndexError: list index out of range

----------------------------------------
Command python setup.py egg_info failed with error code 1
Exception information:
Traceback (most recent call last):
  File "/Library/Python/2.6/site-packages/pip-1.0.2-py2.6.egg/pip/basecommand.py", line 126, in main
    self.run(options, args)
  File "/Library/Python/2.6/site-packages/pip-1.0.2-py2.6.egg/pip/commands/install.py", line 223, in run
    requirement_set.prepare_files(finder, force_root_egg_info=self.bundle, bundle=self.bundle)
  File "/Library/Python/2.6/site-packages/pip-1.0.2-py2.6.egg/pip/req.py", line 986, in prepare_files
    req_to_install.run_egg_info()
  File "/Library/Python/2.6/site-packages/pip-1.0.2-py2.6.egg/pip/req.py", line 222, in run_egg_info
    command_desc='python setup.py egg_info')
  File "/Library/Python/2.6/site-packages/pip-1.0.2-py2.6.egg/pip/__init__.py", line 255, in call_subprocess
    % (command_desc, proc.returncode))
InstallationError: Command python setup.py egg_info failed with error code 1

Answers


I ran into this same error while using the native Python 2.6.1 on Mac OS X 10.6 to install django-imagekit. Some googling revealed this:

https://github.com/jezdez/django_compressor/issues/181

which suggested this:

pip install versiontools

and then I was able to install django-imagekit.


Need Your Help

How to convert a number in Python to 8 binary bytes (64-bit long)?

python python-2.x

How do I convert a number in Python to 8 binary bytes (64-bit long)?

JSFL How do I set the instance name of a text field I just added?

flash textfield jsfl

I've just started working with JSFL in Adobe Flash and I'm trying to add a text field to a newly created layer and then change its instance name to "properties".