URN Logo
UNIX Resources » Linux » Linux Forum » SuSE Linux Support » Page.2 » ZMD error, freeze problem and apparmor warning
announcement The content of this page is collected from Linux Forum, All copyrights and other associated rights are reserved by the original authors of the articles.
Resources
China Linux Forum(finished)
Linux Forum(finished)
FreeBSD China(finished)
linuxforum.com
  LinuxForum General Chat
  Linux Advocacy
  LinuxForum Polls
  Introductions
  Linux Kernel Support
  Patch Management
  Development Release
  Linux Programming
  Linux Security
  Linux Software
  Linux Hardware Problems
    Linux Video Problems
    Linux Sound Problems
  Linux Networking Support
  Linux Printing Support
  Linux Human Interface Devices Support
  Linux Data Storage Support
  Linux Applications Support
  Linux Installation Support
  Linux Laptops Support
  Linux Motherboard, Chipsets, CPU, Memory
  Miscellaneous
  Debian Linux Support
  Ubuntu Linux Support
  LiveCD Discussions
  Gentoo Linux Support
  Mandrake Linux Support
  Redhat / Fedora Linux Support
  Slackware Linux Support
  SuSE Linux Support
  CentOS Linux Support
  Linux Web Servers
  Linux DNS Servers
  Linux Database Servers
  Linux Email Servers
  Linux FTP Servers
  Linux Squid Proxy Server
  Linux Samba Help
  Linux cPanel Help
  Linux Ensim Help
  Linux Plesk Help
  Linux Webmin / Usermin Help
  Qmail Toaster Help
  Linux Games
  Windows Game Emulation
  Linux Discussions
  General Linux Discussions
  Red Hat Linux Discussions
  More Red Hat Linux Discussions
  Mandrake Linux Discussions
  Slackware Linux Discussions
  SuSE Linux Discussions
  Debian Discussions
  Samba Help
  Linux Security
  Linux Networking
  Gentoo Help
  Operating System Rant Forum
  Hardware Rants
   
ZMD error, freeze problem and apparmor warning
Subject: ZMD error, freeze problem and apparmor warning
Author: Tillus    Posted: 2006-09-28 14:48:38    Length: 514 byte(s)
[Original] [Print] [Top]
Having started my machine I get a tiny message:

Software Updater - Error
ZMD does not appear to be running

How can I correct this?

Also, when I try to open YaST-"Hardware"-"Keyboard Layout" the system freezes. Does anyone know why?

And lastly, during start up I get a warning that AppArmor is loading some or other, but it can't sice it's already loaded. Is this something to worry about?


Thanks in advance
Tillus
[Original] [Print] [Top]
Subject: Re: ZMD error, freeze problem and apparmor warning
Author: erdsiger    Posted: 2006-09-28 15:02:44    Length: 364 byte(s)
[Original] [Print] [Top]
Software Updater - Error
ZMD does not appear to be running

As root:

Code:
rczmd start
----
[Original] [Print] [Top]
Subject: Re: ZMD error, freeze problem and apparmor warning
Author: Tillus    Posted: 2006-09-30 14:07:24    Length: 376 byte(s)
[Original] [Print] [Top]
Question is is there a way to have it start on startup?

Also, when I try to get the hardware information in YaST the computer also freezes up

Tillus

Oops! Forgot to mention I'm running SuSE 10.1

Also, when I write rczmd start as root the software installer still doesn't get it. It still complains that ZMD is not running.
[Original] [Print] [Top]
Subject: Re: ZMD error, freeze problem and apparmor warning
Author: Tillus    Posted: 2006-10-02 11:22:06    Length: 1,097 byte(s)
[Original] [Print] [Top]
Turned out there are two files that can cause problems in this case:

/var/lib/zmd/zmd.db                  and
installed-packages-stamp        in the same folder.

Deleting these made my problem disappear (at least as far as I can tell)

For the full support page, visit
https://bugzilla.novell.com/show_bug.cgi?id=191140

Today's date 2006-Oct-02

As for the Apparmor warning that it can't load the profiles, because they are already loaded, this is what Novell had to say:

"We'll look at fixing this in a future version; I don't believe we would ship an
update for 10.1, however. (It's mostly a cosmetic defect..)"

For the full support page see:
https://bugzilla.novell.com/show_bug.cgi?id=198375

Today's date 2006-Oct-02


That leaves YaSTs crashing, when requesting YaST - Hardware - Keyboard Layout, Hardware information and then some.

Ta for now
Tillus
[Original] [Print] [Top]
Subject: Re: ZMD error, freeze problem and apparmor warning
Author: erdsiger    Posted: 2006-10-02 14:23:52    Length: 976 byte(s)
[Original] [Print] [Top]
Question is is there a way to have it start on startup?

I'm sorry just now answering. I don't have any Linux distribution now, unfortunately I deleted a partition on my system and I'll download a LiveDVD of SuSE tomorrow. So I'm not sure if this file exists on SuSE, but if yes, just add the rczmd start command to this file: /etc/conf.d/local.start

Also, when I try to get the hardware information in YaST the computer also freezes up

Can't you see any useful information in you /var/log folder in the log files?
----
[Original] [Print] [Top]
Subject: Re: ZMD error, freeze problem and apparmor warning
Author: Tillus    Posted: 2006-10-02 16:49:54    Length: 711 byte(s)
[Original] [Print] [Top]
You wrote:
unfortunately I deleted a partition on my system and I'll download a LiveDVD of SuSE tomorrow

When I first downloaded the LiveCD I figured I could run SuSE from the CD. Turned out it needed diskspace anyway. So if you aren't comfy with it already, I'd rather download the installation DVD instead.

Thank you for your advise on rczmd start, I'll try it asap. It's so difficult to know where everything goes. Still hanging on though. Also, I'll try the log files. I'll return with the results as soon as I'm done.

Thanks again
Tillus
[Original] [Print] [Top]
Subject: Re: ZMD error, freeze problem and apparmor warning
Author: erdsiger    Posted: 2006-10-03 06:40:22    Length: 1,371 byte(s)
[Original] [Print] [Top]
You wrote:
unfortunately I deleted a partition on my system and I'll download a LiveDVD of SuSE tomorrow

When I first downloaded the LiveCD I figured I could run SuSE from the CD. Turned out it needed diskspace anyway. So if you aren't comfy with it already, I'd rather download the installation DVD instead.

Thanks your advice, but I decided I won't install Linux on my system, I'll use only a LiveDVD. I don't have a large hard disk and if I install SuSE it requires a lot of space. Anyway I can do nearly everything with the LiveDVD (I think). Now I'm in a project and the other members of this project use Windows and in this case, I use often Windows in these weeks.

For your zmd problem: It is possible that you don't have to edit any file, type this command to the console:

Code:
sudo chkconfig -s novell-zmd on

But I'm not sure if it is working. If you don't find the /etc/conf.d/local.start you should edit the /etc/init.d file.
----
[Original] [Print] [Top]
Subject: Re: ZMD error, freeze problem and apparmor warning
Author: Tillus    Posted: 2006-10-03 15:26:31    Length: 629 byte(s)
[Original] [Print] [Top]
Thank you so much for the time you've put into this, but it seems the deleting of the two files in post #3 did the trick. I'll try to look into your latest advise as well as soon as I can find the time.

My remaining problem on this thread is that YaST hangs the computer if I request Keyboard layout, Hardware information and some other thinmgs. Do you think that is because YaST needs updating? In that case how is that done? I already know how to update in general, but I haven't found any way of updating YaST in particular.

Once again, thanks for all the valuable input.

Tillus
[Original] [Print] [Top]
Subject: Re: ZMD error, freeze problem and apparmor warning
Author: erdsiger    Posted: 2006-10-03 15:28:26    Length: 47 byte(s)
[Original] [Print] [Top]
All I can suggest is to look at your log files.
----
[Original] [Print] [Top]
Subject: Re: ZMD error, freeze problem and apparmor warning
Author: Tillus    Posted: 2006-10-05 12:54:41    Length: 223 byte(s)
[Original] [Print] [Top]
I've looked through the log files, but nothing looks out of the ordinary.
I've been looking for a way to present the log files, but there isn't an easy one, since they are all so large.

Tillus
[Original] [Print] [Top]
Subject: Re: ZMD error, freeze problem and apparmor warning
Author: erdsiger    Posted: 2006-10-05 15:26:14    Length: 362 byte(s)
[Original] [Print] [Top]
I've been looking for a way to present the log files.

You can attach them here. Click on the Additional Options under the text field where you write.
----
[Original] [Print] [Top]
Subject: Re: ZMD error, freeze problem and apparmor warning
Author: Tillus    Posted: 2006-10-05 15:56:04    Length: 418 byte(s)
[Original] [Print] [Top]
I'm trying to post the logfiles, but all I get is this error-message:



Your session timed out while posting. Please try to re-submit your message.
No subject was filled in.
The message body was left empty.

wich is quite rediculus, since it's all wrong

So far I've managed to attach two files. Here's hoping for the next two...

Tillus
[Original] [Print] [Top]
Subject: Re: ZMD error, freeze problem and apparmor warning
Author: Tillus    Posted: 2006-10-05 16:14:24    Length: 139 byte(s)
[Original] [Print] [Top]
Seems the other files are in MBs, so they can't be posted.

y2log y2log-1 y2log-2 y2log-3
Sorry


Tillus
[Original] [Print] [Top]
« Previous thread
HP Scanner Sometimes
SuSE Linux Support
Page. 2
Next thread »
Can't authenticate SUSE 10.1 machine to Windows NT Domain
     

Copyright © 2007 UNIX Resources Network, All Rights Reserved.      About URN | Privacy & Legal | Help | Contact us
Powered by FreeBSD    webmaster: webmaster@unixresources.net
This page created on 2007-08-01 12:05:20, cost 0.046272993087769 ms.