URN Logo
UNIX Resources » Linux » Linux Forum » Mandrake Linux Discussions » Page.32 » install problem with the rpm file
announcement The content of this page is collected from Linux Forum, All copyrights and other associated rights are reserved by the original authors of the articles.
Resources
China Linux Forum(finished)
Linux Forum(finished)
FreeBSD China(finished)
linuxforum.com
  LinuxForum General Chat
  Linux Advocacy
  LinuxForum Polls
  Introductions
  Linux Kernel Support
  Patch Management
  Development Release
  Linux Programming
  Linux Security
  Linux Software
  Linux Hardware Problems
    Linux Video Problems
    Linux Sound Problems
  Linux Networking Support
  Linux Printing Support
  Linux Human Interface Devices Support
  Linux Data Storage Support
  Linux Applications Support
  Linux Installation Support
  Linux Laptops Support
  Linux Motherboard, Chipsets, CPU, Memory
  Miscellaneous
  Debian Linux Support
  Ubuntu Linux Support
  LiveCD Discussions
  Gentoo Linux Support
  Mandrake Linux Support
  Redhat / Fedora Linux Support
  Slackware Linux Support
  SuSE Linux Support
  CentOS Linux Support
  Linux Web Servers
  Linux DNS Servers
  Linux Database Servers
  Linux Email Servers
  Linux FTP Servers
  Linux Squid Proxy Server
  Linux Samba Help
  Linux cPanel Help
  Linux Ensim Help
  Linux Plesk Help
  Linux Webmin / Usermin Help
  Qmail Toaster Help
  Linux Games
  Windows Game Emulation
  Linux Discussions
  General Linux Discussions
  Red Hat Linux Discussions
  More Red Hat Linux Discussions
  Mandrake Linux Discussions
  Slackware Linux Discussions
  SuSE Linux Discussions
  Debian Discussions
  Samba Help
  Linux Security
  Linux Networking
  Gentoo Help
  Operating System Rant Forum
  Hardware Rants
   
install problem with the rpm file
Subject: install problem with the rpm file
Author: s88    Posted: 2005-08-29 10:03:26    Length: 398 byte(s)
[Original] [Print] [Top]
howdy:
     when I was installing the autoconf2.5.2 with the rpm file, the
mandrake told me...

m4 is needed by autoconf2.5-2.59-6mdk
   autoconf2.1 is needed by autoconf2.5-2.59-6mdk

     then abort the install process.
     What should I do??? Could anyone help me!

Thanx!

[Original] [Print] [Top]
Subject: install problem with the rpm file
Author: Bit Twister    Posted: 2005-08-29 10:19:19    Length: 2,084 byte(s)
[Original] [Print] [Top]
On 29 Aug 2005 09:03:26 -0700, s88 wrote:
QUOTE
howdy:

G'day to you.

QUOTE
when I was installing the autoconf2.5.2 with the rpm file, the
mandrake told me...

Please read http://www.catb.org/~esr/faqs/smart-questions.html
Always provide distribution, release, when posting questions.
It could help you get better answers.
Showing exactly what you did and what you received can realy help.


QUOTE
m4 is needed by autoconf2.5-2.59-6mdk
   autoconf2.1 is needed by autoconf2.5-2.59-6mdk

then abort the install process.
What should I do???

Install the dependencies.
It is not called dependency hell for nothing.  :(

QUOTE
Could anyone help me!

I would use http://easyurpmi.zarb.org to setup main/updates/contrib values
and use urpm* commands to manage software. Much easier.  :)

That way you could have done a _urpmi autoconf_ and it would have
installed all dependencies.

for extra points
apropos urpm

and    man cmd_here      for each one returned by the above command.

[Original] [Print] [Top]
Subject: install problem with the rpm file
Author: Masrur Hossain    Posted: 2005-08-29 10:22:17    Length: 820 byte(s)
[Original] [Print] [Top]
s88 wrote:
QUOTE
howdy:
when I was installing the autoconf2.5.2 with the rpm file, the
mandrake told me...

m4 is needed by autoconf2.5-2.59-6mdk
   autoconf2.1 is needed by autoconf2.5-2.59-6mdk

then abort the install process.
What should I do??? Could anyone help me!

Thanx!


Wondering if you are trying to upgrade from 2.1 to 2.5
To upgrade
              rpm -U autoconf2.5.2*.rpm

and probably the  "m4"  package is also missing .


regards
Masrur

[Original] [Print] [Top]
Subject: install problem with the rpm file
Author: Dan Espen    Posted: 2005-08-29 14:56:08    Length: 866 byte(s)
[Original] [Print] [Top]
Masrur Hossain [masrur@invl.com] writes:

QUOTE
s88 wrote:
howdy:
when I was installing the autoconf2.5.2 with the rpm file, the
mandrake told me...
m4 is needed by autoconf2.5-2.59-6mdk
   autoconf2.1 is needed by autoconf2.5-2.59-6mdk
then abort the install process.
What should I do??? Could anyone help me!
Thanx!


Wondering if you are trying to upgrade from 2.1 to 2.5
To upgrade
rpm -U autoconf2.5.2*.rpm

On a Mandrake system, never use rpm directly.
Always use the 'urpmi' command.

As another poster already mentioned, google for 'easy urpmi'.

[Original] [Print] [Top]
« Previous thread
KPM Won't Copy
Mandrake Linux Discussions
Page. 32
Next thread »
thunderbird problem
     

Copyright © 2007 UNIX Resources Network, All Rights Reserved.      About URN | Privacy & Legal | Help | Contact us
Powered by FreeBSD    webmaster: webmaster@unixresources.net
This page created on 2007-08-01 12:23:08, cost 0.024903059005737 ms.