URN Logo
UNIX Resources » Linux » Linux Forum » Gentoo Help » Page.10 » SRC_URI seems to be ignored in a homemade ebuild
announcement The content of this page is collected from Linux Forum, All copyrights and other associated rights are reserved by the original authors of the articles.
Resources
China Linux Forum(finished)
Linux Forum(finished)
FreeBSD China(finished)
linuxforum.com
  LinuxForum General Chat
  Linux Advocacy
  LinuxForum Polls
  Introductions
  Linux Kernel Support
  Patch Management
  Development Release
  Linux Programming
  Linux Security
  Linux Software
  Linux Hardware Problems
    Linux Video Problems
    Linux Sound Problems
  Linux Networking Support
  Linux Printing Support
  Linux Human Interface Devices Support
  Linux Data Storage Support
  Linux Applications Support
  Linux Installation Support
  Linux Laptops Support
  Linux Motherboard, Chipsets, CPU, Memory
  Miscellaneous
  Debian Linux Support
  Ubuntu Linux Support
  LiveCD Discussions
  Gentoo Linux Support
  Mandrake Linux Support
  Redhat / Fedora Linux Support
  Slackware Linux Support
  SuSE Linux Support
  CentOS Linux Support
  Linux Web Servers
  Linux DNS Servers
  Linux Database Servers
  Linux Email Servers
  Linux FTP Servers
  Linux Squid Proxy Server
  Linux Samba Help
  Linux cPanel Help
  Linux Ensim Help
  Linux Plesk Help
  Linux Webmin / Usermin Help
  Qmail Toaster Help
  Linux Games
  Windows Game Emulation
  Linux Discussions
  General Linux Discussions
  Red Hat Linux Discussions
  More Red Hat Linux Discussions
  Mandrake Linux Discussions
  Slackware Linux Discussions
  SuSE Linux Discussions
  Debian Discussions
  Samba Help
  Linux Security
  Linux Networking
  Gentoo Help
  Operating System Rant Forum
  Hardware Rants
   
SRC_URI seems to be ignored in a homemade ebuild
Subject: SRC_URI seems to be ignored in a homemade ebuild
Author: Leif Burrow    Posted: 2005-06-19 20:51:48    Length: 1,013 byte(s)
[Original] [Print] [Top]
Hello,

I'm new to writing ebuilds but would like to get in to it. At the moment I
am trying to write an ebuild for soundmodem.  Unfortunately I'm runing in
to a problem.  I have the line
SRC_URI="http://www.baycom.org/~tom/ham/soundmodem/soundmodem-${P}.tar.gz"
in my ebuild. The filename is soundmodem-0.9.ebuild, I have it
in /usr/local/portage/media-radio/soundmodem.  I also created a files
subdir inside of soundmodem. I have PORTDIR_OVERLAY="/usr/local/portage" in
my make.conf file.

When I try to create a digest by typing
 (ebuild /usr/local/portage/media-radio/soundmodem/soundmodem-0.9.ebuild
digest) it tries to download soundmodem-0.9.tar.gz but not from the domain
I have in the SRC_URI. It is trying to download it from the portage
mirrors.

I have played with it all night long but cannot figure out why this is
happening.

TIA for any help!

Leif

[Original] [Print] [Top]
Subject: SRC_URI seems to be ignored in a homemade ebuild
Author: Anno v. Heimburg    Posted: 2005-06-22 02:46:49    Length: 630 byte(s)
[Original] [Print] [Top]
Leif Burrow wrote:


QUOTE
SRC_URI="http://www.baycom.org/~tom/ham/soundmodem/soundmodem-${P}.tar.gz"

Are you sure you want that? ${P} expands to package name and version, so the
file you are specifying is

http://www.baycom.org/~tom/ham/soundmodem/...odem-0.9.tar.gz

Anno.

[Original] [Print] [Top]
« Previous thread
SRC_URI seems to be being ignored in a custom ebuild
Gentoo Help
Page. 10
Next thread »
Backgrounding a startup script
     

Copyright © 2007 UNIX Resources Network, All Rights Reserved.      About URN | Privacy & Legal | Help | Contact us
Powered by FreeBSD    webmaster: webmaster@unixresources.net
This page created on 2007-08-01 13:18:21, cost 0.022088050842285 ms.